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SeaTTY v2.65 

SeaTTY — Version history | Downloads and Registration 

A program to receive weather reports, navigational warnings and weather 
charts transmitted in RTTY, NAVTEX, PACTOR-1 FEC and HF-FAX (WEFAX) 

modes on longwave and shortwave bands. It can decode GMDSS DSC (HF 
and VHF) messages. Software also can automatically save NOAA Weather 

Radio SAME voice messages (NWR SAME) and them digital headers. 
No additional hardware is required — you need only a receiver 

and computer with a sound card. 

Platform: Windows XP/Vista/7/8/10/11 

    

 

 

 

  

    

    

 

 

 

  

    

The author’s program overview 

The working area of the program is divided into several windows, the sizes 

of which can be changed by the user by dragging the borders. 

https://www.dxsoft.com/en/products/seatty/history/
https://www.dxsoft.com/en/products/seatty/#bottom
https://www.dxsoft.com/image/screenshot/seatty_big.gif
https://www.dxsoft.com/image/screenshot/seatty_2_big.gif
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In the top window the current spectrum of a signal (blue line) and a peak 

detector of spectral components (green line) are shown. Ruler under this 

window shows frequencies of sound spectrum. The long vertical red lines 
in this window show the working frequencies of the decoder filters. 

In FAX mode these lines show "black" and "white" frequencies. To change 
the center frequency, click on the desired frequency (probably between 

the peaks).  
 

The bottom window shows an oscillogram of the decoded signal. This 
window can be hide by the "Setup->View->Show 

oscillogram window" option 
  

The "Setup->View->Logarithmic spectrogram scale" option or Alt-
Z hotkey switch spectrogram window between linear or logarithmic scale. 

Analogously, the "Setup->View->Logarithmic oscillogram scale" 
option or Ctrl-Z hotkey switch oscillogram scale. Logarithmic scale is 

more convenient usually, but it needs more computer resources. 

 
The "SQL" button switches squelch on. The number to the left of the 

"SQL" button determines the squelch threshold. When squelch is switched 
on, the horizontal red line shows the squelch threshold in spectrogram 

window. 
 

The "AFC" button (auto frequency control) adjusts the long red lines 
(working frequencies) to the closest peak frequencies. The numbers to the 

left of the AFC button determines the limits of AFC. The first number 
is local deviation in hertzs, i.e. maximal deviation from current 

frequency. Second number is global deviation in hertzs, i.e. maximal 
deviation from last user-selected frequency. User-selected frequencies are 

shown at spectrogram by short red lines . 
 

In HF-FAX mode AFC works during phase lines receiving only. These 

phasing lines are transmitted just before real image transmitting. 
In NWR-SAME and GMDSS DSC VHF modes AFC doesn't work, because 

frequencies are defined by protocol specifications. 
 

The "Reverse/Normal" button defines decoded signal polarity. For 
weather station you should use "Normal" position with USB receiver or 

"Reverse" position with LSB receiver in RTTY, NAVTEX, PACTOR-1 FEC 
and FAX modes. Amateur RTTY radio station and some commercial station 

use opposite polarity. In NWR-SAME mode this option is ignored. 
 

The "Mode" menu selects a working mode (RTTY, NAVTEX, HF-
FAX, NWR-SAME, GMDSS DSC - HF, GMDSS DSC - VHF). 

 
Signal speed and frequency shift in RTTY mode are selected via the 

"Speed" and "Shift" menus respectively. 
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Weather stations use 50 Baud speed. They use 85 Hz shift in the 
longwave band and 450 Hz shift in shortwave bands usually. Amateur 

stations use 45 Baud speed and 170 Hz shift usually. Commercial stations 

use 50 Baud speed and 170 Hz shift usually.  
 

The "Shift" menu is used to select normal deviation (800 Hz) or narrow 
deviation (300 Hz) in HF-FAX mode also. Narrow deviation is used at long 

wave band. 
 

The "Setup->Text->Fast synchronization in NAVTEX" menu option 
define synchronization method in NAVTEX mode. 

When this option is selected, program can synchronize with receiving 
signal much faster, because it doesn't need special idle symbols to do it. 

But there is chance to make incorrect synchronization in that case. 
 

The "OnTop" button puts SeaTTY in front of all windows. 
 

Received symbols are displayed on the second from top window. The 

menu option "File->Clear Buffer" clears this window. If the "Setup-
>Text->Clear Rx window once a day" option is selected, this window 

is cleared automatically at start of a day. 
 

The program writes received  symbols in raw log file in the "RAW_LOGS" 
folder. A name of log file is date-stamped. For example, "01-10-08.TXT" 

is raw log file for 08 October 2001.If the "Setup->Text->Put time-
stamps in raw logs" option is checked, SeaTTY writes receiving time at 

beginning of each string of a raw log file. 
 

All weather messages and SAME headers start with "ZCZC" sequence and 
finish by "NNNN" sequence. SeaTTY finds these sequences in symbol 

stream and writes messages separately in the "Messages" folder. A name 
of message file is time-stamped. Four symbols after "ZCZC" sequence 

is Station ID in NAVTEX mode. Similar message ID is used in RTTY mode 

also. If station ID is found in a message, it is included in a filename. 
 

For example, "011121-225525-KA56.TXT" is a message with station ID 
"KA56" saved at 22:55:25 on 21 November 2001. 

To reduce chance to miss message for noise SeaTTY starts to write 
message if at least three symbols of "ZCZC" sequence is received. 

In NWR-SAME mode SeaTTY writes voice messages to wave-files and 
headers to text files, for example  "011121-225525.WAV" 

and  "011121-225525.TXT". 
 

Station ID filter can be enabled at "Setup/Filters" page. If "Use ID filter 
in RTTY" option is selected, only messages with appropriate message ID 

are saved in RTTY mode. Analogously, if "Use ID filter in NAVTEX" 
option is selected, only messages with appropriate station ID are saved in 

NAVTEX mode. Filter list includes 4-symbols mask, which can consist of 
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digits, letters, "?" and "#" symbols. "?" means "any symbol", "#" means 
"any digit". "Add" button ads filter mask to the list, "Delete" button 

deletes mask from the list. 

 
If the "Setup->Filters->Don't save SYNOP messages" option is 

selected, SeaTTY doesn't save SYNOP messages. These messages are not 
human-readable and consist of groups of digits. 

 
If message was started or stopped manually, it is saved nevertheless filter 

settings. 
  

The "Setup->Text->Use UTC time" option defines if the program use 
UTC or local time. 

 
The "Start" button is used to start message receiving manually, without 

"ZCZC" header. The same button has "Stop" caption while message 
receiving and can be used to stop message receiving before "NNNN" 

footer. 

 
Images received in HF-FAX modes are saved in "Messages" folder also. 

For example, "030710-153027.PNG" is an image saved at 15:30:27 on 
10 July 2003. 

 
 

The left bottom window shows a tree of received messages and images. 
The right bottom window shows a text of selected message or preview of 

selected image. "M-" and "M+" buttons are used to change the scale 
of  images. 

 
To open message file in a text editor, open image file in an image editor 

or to play voice message, make double-click at the message window or at 
the tree window. If date is selected raw log file opens. 

 

To delete message or image, select it and press "Delete" key. To delete 
all messages and images for one day, select desired date in the tree and 

press "Delete" key. 
 

The option "Unshift On Space" is switched on and off via the "Setup-
>Text->Unshift on space" menu. When that option is selected, 

receiving symbol shift is switched to a "Letters" after receiving "Space" or 
"Line Feed" symbol. 

 
Manual switching of receiving symbol shift can be made by keyboard. Gray 

"*" or Alt-(gray "*") is Figures and gray "-" or Alt-(gray "-") is Letters. 
 

The options "Setup->Text->RTTY alphabet->English charset", 
"Setup->Text->RTTY alphabet->Russian charset", 

"Setup->Text->RTTY alphabet->Swedish Charset" and "Setup-
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>Text->RTTY alphabet->English/Russian Extended charset" select 
the alphabet to be used. 

 

The "Setup->Text->Extended Baudot" option switches on the extended 
code table (with high and low letters). 

 
The "File->Open Wave Capture File" command opens wave-file to save 

all received from soundcard sound. File is closed by the "File->Close 
Wave Capture File" command. The hotkey for these commands is Alt-V. 

Take to attention that a minute of sound recording need above 1 MByte 
disk space. 

 
SeaTTY can decode signals from a WAVE-file. Desired file is selected by 

the "File->Decode From File" command. 
A WAVE-file must be Windows PCM file, without compression. A sample 

rate must be 11025, 22050 or 44100 Hz. Preferred file parameters are 
mono, 16 bit, 11025 Hz. 

 

The windows appearance can be changed at the "Setup->Fonts & 
colors" page. 

 
There are two methods to correct sound card sampling rate variation 

against nominal frequency (11025 Hz). The first method is 
the SamplingFreq parameter of the [RTTY] section of the SEATTY.INI 

file, f.e. SamplingFreq=11020.56 . The second way is /s parameter of 
the command line, f.e. SEATTY.EXE /s 11030.5 . Any of these 

parameters define real sampling frequency. When both parameters are 
defined, the command line parameter has priority. SeaTTY can calculate 

and save real sampling frequency automatically during slant 
correction in HF-FAX mode. See details there. 

 
Selected options of the program are saved by "Setup->Save" button. 

Options are written into the file SEATTY.INI . The program looks for this 

file in the working directory. If SEATTY.INI file is not found in a working 
directory, working directory is changed to a default value. You can have 

several variants of the ini-file for different situations. Just create several 
shortcuts to SEATTY.EXE each with a different working directory and 

copy SEATTY.INI file to each of this directories. 
 

In HF-FAX mode additional window is opened. 
 

"Auto S." button switch on "Auto Start / Auto Stop" mode. When this 
button is pressed and special start signal (APT tone) is received SeaTTY 

begins to receive image automatically. If this button is pressed and stop 
signal is received, SeaTTY stops receiving and save image automatically. 

 
The start signal is black/white sequence with frequency of 300 or 675 Hz . 

The stop signal is black/white sequence with frequency of 450 Hz. 

https://www.dxsoft.com/en/products/seatty/hs18.htm#slant_correction_target
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To start receiving manually, click on "Start" button. If you click on "Start" 

button while image receiving, received image will be dropped and 

receiving will be re-started. 
 

To stop receiving manually, click on "Stop" button. Manually stopped 
image is not saved automatically. To save manually stopped or changed 

image, click on "Save" button. 
 

"->||<-" button is used to rotate image horizontally if image is not 
synchronized properly. Click to this button, then click to point of image 

which should be moved to left side of image (start of line). Click on "Save" 
button to save changed image. 

 
"<-/|\->" button is used for slant correction. Vertical lines of received 

image are slanted when sound card sampling frequency difference from 
nominal one. Slant correction, at first, fix received image and, at second, 

calculate real sampling frequency to avoid slant distortion in future 

receiving. 
 

To make slant correction you need to have received image in receiving 
window. Receiving should be stopped. Find a line whish should be vertical 

on an image. Click on the slant correction button. Click on the start of this 
line, then click on the end of this line. SeaTTY will ask if it must save 

calculated sampling frequency to the ini-file. Select "Yes" to apply changes 
and save calculated frequency to ini-file. Select "No" to apply changes, but 

not save calculated frequency to ini-file. At least, click "Cancel" to cancel 
changes. Click on "Save" button if your want to save changed image. 

 
SeaTTY tries to define transmission speed in lines per minute (LPM) and 

image resolution (index of cooperation - IOC) automatically. If automatic 
detection is fail, SeaTTY use values from LPM and IOC fields. 

 

"M-" and "M+" buttons are used to change the scale of receiving image. 
 

In the status line of the window image scale, LPM and IOC are shown. 

There are short messages about receiving process also. 

 


